Please explain Version 2.0 is NOT compatible with older vers

Post bugs here!
Post Reply
kevinotton
Posts: 39
Joined: Thu May 15, 2014 8:18 am
Location: Needham Market, Suffolk, UK

Please explain Version 2.0 is NOT compatible with older vers

Post by kevinotton »

This is not a very clear comment

Please explain in detail. How do I migrate 'old' projects as a lot has changed.

Kevin

Update: I have found many of the changes in older files i.e. ._xxxxx code is now xui.xxxxx. _arr _each.

Are any of the templates or examples converted / rewritten in V2? I have added a few new pages and they look like V1.4 templates. Still have the screen dimensions at the bottom of the file that real v2 no longer have.

Martin
Posts: 14
Joined: Wed Oct 26, 2016 2:43 pm

Re: Please explain Version 2.0 is NOT compatible with older

Post by Martin »

Yes, please let us know the differences. I'm on 1.42 with a very large SPA that I'd like to keep pace with CrossUI releases. I can't do that until I know if the new version offers features that are needed, is stable, and if there are migration issues. I see the demo site now shows a CSS editor but I'm hoping that the output would also work for older versions. Can you put together a list of new features and project migration considerations?

support
Posts: 356
Joined: Sat Apr 27, 2013 9:22 am

Re: Please explain Version 2.0 is NOT compatible with older

Post by support »

To upgrade ver1.4 to ver2.0

1)Find all '_.xxx', modify them to 'xui.xxx';
2)Find all 'Class(', modify them to 'xui.Class(';
3)Find all 'NameSpace(', modify them to 'xui.NameSpace(';
4)If you used following widgets: Range/Poll/TagEditor/ColLayout/Calendar/TimeLine, you have to replace them with other widgets or other solution.
5)If you used 'aqua' or 'blackwhite' theme, you have to use other existing theme.
6)Debug your app in chrome, if you find some undefined properties/events/functions, try to replace or delete them.
7)And if you find other problems you cant solve, just post here, I'll help you out

support
Posts: 356
Joined: Sat Apr 27, 2013 9:22 am

Re: Please explain Version 2.0 is NOT compatible with older

Post by support »

And we offer free upgrading service for commercial users ( Non-Profit users are not included) .

Post Reply